विंडोज 10 में टीएलएस 1.3 को सक्षम या अक्षम कैसे करें

टीएलएस 1.3 नवीनतम सुरक्षा प्रोटोकॉल है जो सुरक्षा और प्रदर्शन के मामले में टीएलएस 1.2 में सुधार करता है। टीएलएस 1.3 अभी भी व्यापक रूप से उपयोग नहीं किया जाता है लेकिन कुछ वेबसाइट और वेब सर्वर टीएलएस 1.3 प्रोटोकॉल का समर्थन करते हैं।

यदि आपके ब्राउज़र या ऑपरेटिंग सिस्टम में TLS 1.3 सक्षम है, तो इस संस्करण का समर्थन करने वाली वेबसाइटें और ऐप्स, TLS 1.3 के साथ सिस्टम की समग्र सुरक्षा को बढ़ाने और समग्र प्रदर्शन अनुभव को बढ़ाने के साथ खुलेंगे।

इस लेख में, हम विंडोज 10 में टीएलएस 1.3 को सक्षम या अक्षम करने के बारे में चर्चा करेंगे। हम Google क्रोम, माइक्रोसॉफ्ट एज और मोज़िला फ़ायरफ़ॉक्स सहित लोकप्रिय ब्राउज़रों में टीएलएस 1.3 को सक्षम करने पर भी चर्चा करेंगे। त्वरित सारांश छिपाना 1 एसएसएल (1, 2, 3) बनाम टीएलएस (1.1, 1.2) बनाम टीएलएस 1.3 १.१ Windows 10 में TLS 1.3 सक्षम करें (सिस्टम-व्यापी) 1.2 Microsoft Edge और Internet Explorer पर TLS 1.3 सक्षम करें 1.3 Google क्रोम पर टीएलएस 1.3 सक्षम करें १.४ Mozilla Firefox पर TLS 1.3 सक्षम करें 2 मैं कैसे जांचूं कि टीएलएस 1.3 सक्षम है या नहीं? 3 समापन शब्द

एसएसएल (1, 2, 3) बनाम टीएलएस (1.1, 1.2) बनाम टीएलएस 1.3

एसएसएल (सिक्योर सॉकेट लेयर) प्रोटोकॉल को नेटस्केप द्वारा वेबसाइट और ब्राउज़र के बीच संचार को सुरक्षित करने के लिए विकसित किया गया था। यह संस्करण 2 और 3 के साथ विकसित हुआ।

जब मानक का विस्तार हुआ, तो इसे टीएलएस नाम दिया गया लेकिन अनिवार्य रूप से बुनियादी तकनीक वही रहती है।

प्रत्येक संस्करण अद्यतन के साथ, TLS अधिक सुरक्षा सुविधाएँ और प्रदर्शन संवर्द्धन जोड़ता है। टीएलएस 1.2 सबसे व्यापक रूप से इस्तेमाल किया जाने वाला प्रोटोकॉल है जिसे सुरक्षित भी माना जाता है जबकि टीएलएस 1.0 और टीएलएस 1.1 को सुरक्षित नहीं माना जाता है।

टीएलएस 1.3 में आपको मिलने वाली कुछ विशेषताएं यहां दी गई हैं:

  • नए सुरक्षा सिफर : टीएलएस 1.3 नए सुरक्षा सिफर का उपयोग करता है और पुराने के साथ संगत नहीं है।
  • हटाई गई कमजोर सुरक्षा : कमजोर सुरक्षा एन्क्रिप्शन को हटा दिया गया है और यह TLS 1.3 जैसे, MD5, RC4 आदि के साथ काम नहीं करेगा।
  • स्पीड : टीएलएस 1.3 संख्या को कम करके क्लाइंट/सर्वर संचार को गति देता है। बातचीत के लिए आवश्यक कनेक्शन यात्राओं की।
  • कोई निगरानी नहीं : संगठन और निगरानी सॉफ्टवेयर टीएलएस 1.3 का उपयोग करके सुरक्षित कनेक्शन की निगरानी करने में सक्षम नहीं होंगे। यह संगठनों के लिए एक बड़ी चिंता है जबकि उपयोगकर्ताओं के लिए एक अच्छी राहत है।

Windows 10 में TLS 1.3 सक्षम करें (सिस्टम-व्यापी)

विंडोज 10 में टीएलएस 1.3 डिफ़ॉल्ट रूप से सक्षम नहीं है। यदि आप ऐसे नेटवर्क ऐप्स का उपयोग कर रहे हैं जिनके लिए टीएलएस 1.3 की आवश्यकता है या समर्थन करते हैं, तो आपको विंडोज 10 में टीएलएस 1.3 को सक्षम करना चाहिए। आप विंडोज 10 में टीएलएस 1.3 को सक्षम करने के लिए reg फाइल का उपयोग कर सकते हैं और इसे अपने सिस्टम पर चला सकते हैं।

TLS 1.3.reg सक्षम करें (205 बाइट्स, 3,176 हिट्स)

आपने अब सिस्टम-वाइड TLS 1.3 को सक्षम करने के लिए सिस्टम रजिस्ट्री में आवश्यक परिवर्तन किए हैं।

यदि आप TLS 1.3 को अक्षम करना चाहते हैं, तो आप निम्न रजिस्ट्री फ़ाइल चला सकते हैं:

टीएलएस 1.3.reg अक्षम करें (अज्ञात, 1,362 हिट)

Microsoft Edge और Internet Explorer पर TLS 1.3 सक्षम करें

चूंकि टीएलएस 1.3 डिफ़ॉल्ट रूप से अक्षम है, इसलिए इसे प्रत्येक ब्राउज़र के लिए मैन्युअल रूप से सक्षम करने की आवश्यकता है। वर्तमान में, इंटरनेट एक्सप्लोरर 11 और एज टीएलएस 1.3 का समर्थन नहीं करते हैं, लेकिन आने वाले अगले अपडेट में समर्थित होंगे, सूत्रों के अनुसार माइक्रोसॉफ्ट इनसाइडर प्रोग्राम .

यदि आप प्रयोगात्मक संस्करण को सक्षम करना चाहते हैं, तो इसे माइक्रोसॉफ्ट एज के साथ-साथ इंटरनेट एक्सप्लोरर पर सक्षम करने के लिए नीचे दिए गए चरणों का पालन करें।

  1. प्रकार : Inetcpl.cpl रन और प्रेस में प्रवेश करना .
  2. इंटरनेट गुण में, उन्नत टैब पर जाएं और नीचे की ओर स्क्रॉल करें। टीएलएस 1.3 का उपयोग करें के बगल में स्थित बॉक्स को चेक करें।
    टीएलएस एज सक्षम करें
  3. अप्लाई एंड ओके पर क्लिक करें। परिवर्तनों को प्रभावी करने के लिए अपने कंप्यूटर को रिबूट करें।

एज ब्राउज़र का उपयोग अब टीएलएस 1.3 चलाने वाली किसी भी वेबसाइट या सर्वर से कनेक्ट करने के लिए किया जा सकता है। यह विन्यास भी होता है इंटरनेट एक्स्प्लोरर साथ ही साथ।

आप टीएलएस 1.3, या किसी अन्य संस्करण को नेविगेट करके अक्षम भी कर सकते हैं इंटरनेट गुण विंडो और संबंधित बॉक्स को अनचेक करना।

Google क्रोम पर टीएलएस 1.3 सक्षम करें

गूगल के मामले में क्रोम , TLS 1.3 को चलाने के लिए ध्वज को सक्षम पर सेट करने की आवश्यकता है।

  1. गूगल क्रोम पर एड्रेस बार में निम्नलिखित लिखें:
    chrome://flags
  2. खोज टीएलएस खोज पट्टी में।
    क्रोम टीएलएस सर्च
  3. के आगे ड्रॉप-डाउन मेनू में टीएलएस 1.3 स्थानीय एंकरों के लिए सख्त , चुनते हैं सक्रिय .
    टीएलएस 1 3 सख्त
  4. अब क्लिक करें पुन: लॉन्च पन्ने के तल पर।

यह अब लागू नई सेटिंग्स के साथ क्रोम को फिर से लॉन्च करेगा, और टीएलएस 1.3 अब सक्षम हो जाएगा।

यदि आपको कभी भी Google Chrome पर TLS 1.3 को अक्षम करने की आवश्यकता हो, तो बस यहां जाएं झंडे पेज और चुनें विकलांग ड्रॉप-डाउन मेनू से।

Mozilla Firefox पर TLS 1.3 सक्षम करें

मोज़िला फ़ायरफ़ॉक्स में टीएलएस 1.3 चलाने का एक अनूठा तरीका भी है।

  1. Firefox पर पता बार में निम्नलिखित दर्ज करें:
    about:config
  2. यदि आपको के साथ प्रस्तुत किया जाता है सावधानी के साथ आगे बढ़ें पेज, क्लिक करें जोखिम स्वीकार करें और जारी रखें .
    फ़ायरफ़ॉक्स सावधानी के साथ आगे बढ़ें
  3. पृष्ठ के शीर्ष पर एक खोज बार होगा। निम्नलिखित दर्ज करें:
    security.tls.version.max
  4. अब डबल क्लिक करें सुरक्षा.tls.संस्करण.अधिकतम और मान को . में बदलें 4 .
    फ़ायरफ़ॉक्स परिवर्तन टीएलएस मूल्य
  5. ब्राउज़र को फिर से लॉन्च करें और अब आपके पास मोज़िला फ़ायरफ़ॉक्स पर टीएलएस 1.3 चल रहा होना चाहिए।

यदि आप सेटिंग पर वापस जाना चाहते हैं, तो बस का मान बदलें सुरक्षा.tls.संस्करण.अधिकतम प्रति 3 , और ब्राउज़र को फिर से लॉन्च करें।

मैं कैसे जांचूं कि टीएलएस 1.3 सक्षम है या नहीं?

यदि आप अभी भी संदेह में हैं कि क्या टीएलएस 1.3 कार्यात्मक है, तो आप द्वारा प्रदान किए गए पृष्ठ पर नेविगेट कर सकते हैं क्लाउडफ्लेयर प्रति जांचें कि क्या टीएलएस 1.3 सक्षम है या नहीं। यह एक त्वरित स्कैन चलाता है और आपको उस ब्राउज़र के बारे में कुछ विशिष्ट जानकारी देता है जिसका आप वर्तमान में उपयोग कर रहे हैं।

एक और उपयोगी वेबसाइट है क्वालिस द्वारा एसएसएल लैब्स टीएलएस 1.3 की जांच करने के लिए।

समापन शब्द

Microsoft 2004 के संस्करण के बाद Windows 10 के सभी संस्करणों पर डिफ़ॉल्ट रूप से TLS 1.3 को सक्षम करने की योजना बना रहा है।

कृपया ध्यान दें कि माइक्रोसॉफ्ट एज लीगेसी और इंटरनेट एक्सप्लोरर टीएलएस 1.3 का समर्थन नहीं करेंगे। सुरक्षा और बेहतर प्रदर्शन के साथ आगे बढ़ने के लिए आपको अपने ब्राउज़र को क्रोमियम आधारित एज ब्राउज़र में अपग्रेड करना होगा।

Microsoft नए बिल्ड पर डिफ़ॉल्ट रूप से TLS 1.1 और 1.2 को अक्षम करने की भी योजना बना रहा था, लेकिन वैश्विक महामारी ने उन्हें 2021 के वसंत तक इसे विलंबित करने के लिए मजबूर किया है।

आपको क्या लगता है कि टीएलएस 1.3 का उपयोग करने के लिए अनिवार्य किया जाना चाहिए? क्या आपको कोई गंभीर खतरा था, या आप एन्क्रिप्शन प्रोटोकॉल द्वारा बचाए गए थे?